Willkommen Gast. Bitte Einloggen oder Registrieren
 
Sprache wählen:
 
 
Statistik Version 11 online.

  ÜbersichtHilfeSuchenEinloggenRegistrieren  
 
Seitenindex umschalten Seiten: 1
Thema versenden Drucken
Webstat v11 - keine Einträge in Datenbank (Gelesen: 575 mal)
Radioven
Full Member
***
Offline



Beiträge: 132
Geschlecht: male
Webstat v11 - keine Einträge in Datenbank
27.10.22 um 10:43:54
 
Hallo zusammen,

ich habe die Version 11 zunächst als Update, später dann auch als Neuinstallation ausprobiert.
Die Installation verlief problemlos, alle Dateirechte wurden korrekt gesetzt (Sysinfo komplett grün). Nur erfolgte nach Seitenbesuch leider kein Eintrag in die Datenbank. Ich habe dann, um eigene Fehler völlig auszuschließen, Version 5.3 und Version 11 über ein ganz einfaches HTML-Script parallel angesprochen. Dabei ergab sich folgendes Resultat:
Bei Version 5.3 erfolgte ein Datenbankeintrag, bei Version 11 nicht.

Der leider erst zu spät durchgeführte Syscheck-->Aufzeichnung ergab: Während bei Version 5.3 - wie gefordert - 3 Einträge in die Datenbank erfolgten, war es bei Version 11 nur 1 Eintrag.


Ich vermute an dieser Stelle die Ursache für das Verhalten der Statistik.

In der Hoffnung auf die rettende Antwort
Radioven
Zum Seitenanfang
 
 
IP gespeichert
 
Radioven
Full Member
***
Offline



Beiträge: 132
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #1 - 04.11.22 um 16:30:00
 
Nachdem ich nun beide Statistik-Versionen einige Tage parallel habe laufen lassen, durfte ich folgendes registrieren:
Es gab Besucher, die nur von der alten Statistik 5.3 gezählt wurden. Es handelte sich dabei um Besucher, die mit dem Browser Chrome unterwegs waren. Besucher, die Safari benutzten, wurden dagegen auch von der neuen Version 11 gezählt.
Natürlich habe ich jetzt einen Selbstversuch durchgeführt, meine Cookies gelöscht und anschließend die eigene Webseite besucht.

Das Resultat:
Bei Chrome 107.0 sowie den aktuellen Versionen von Edge und Opera werden Besucher nur von Webstat v5.3 gezählt, bei Firefox 106.04 von beiden Versionen.
Safari konnte ich als Windows-Benutzer selbst nicht testen, scheint aber auch bei beiden Versionen zu funktionieren.

Mich bringen diese Erkenntnisse zwar nicht weiter, aber vielleicht sind sie ein brauchbarer Hinweis für die Entwickler der Statistik.

Gruß
Radioven
Zum Seitenanfang
 
 
IP gespeichert
 
Holger
Administrator
*****
Offline



Beiträge: 2267
Germany NRW
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #2 - 05.11.22 um 07:51:43
 
Hallo radioven,

zunächst einmal vielen Dank für Dein Feedback.

Betreff Testeintrag
Nutzer der Version 11 werden nur noch einen Testeintrag erhalten da in dieser Version das noscript weggefallen ist. Der Testhinweis verankert in der Sprachdatei sollte allerdings angepasst werden, Danke dafür.

Betreff 2 parallele Statistiken
Man könnte meinen dieses so testen zu können, ist aber leider nicht so. Hingegen Deinem ersten Posting dürfen wir also zunächst feststellen, dass die Version 11 sehrwohl Logs aufnimmt.
Das Tracken in 2 parallel laufende Statistiken führt aber genau zu dem Ergebnis wie Du es beschreibst. Die zweite Stat hat hierbei immer das Nachsehen und von daher ist dieser Test so nicht möglich.
Nimm mal die Version 5.3 aus Deiner Testumgebung raus und Du wirst sehen, jetzt taucht auch der Chrome in Version 11 auf.

Holger
Zum Seitenanfang
 

... ... ...
Homepage  
IP gespeichert
 
Radioven
Full Member
***
Offline



Beiträge: 132
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #3 - 05.11.22 um 08:24:00
 
Hallo Holger,

vielen Dank für die Antwort. Ich habe nun zunächst mal die Reihenfolge der Aufrufe des Tracking-Scripts geändert, also jetzt zuerst Version 11, dann Version 5.3. Mal sehen, was nun passiert.

Dennoch verstehe ich nicht, wieso die Parallelaufzeichnung mit Firefox und Safari funktioniert hat, mit den Browsern auf Chrome-Basis dagegen nicht.

Gruß
Radioven
Zum Seitenanfang
 
 
IP gespeichert
 
Radioven
Full Member
***
Offline



Beiträge: 132
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #4 - 05.11.22 um 11:58:21
 
Da ich heute schon vier Besucher auf meiner Webseite hatte, kann ich bereits mit ersten Ergebnissen aufwarten. Leider sehen diese genauso aus wie vorher, obwohl die Version 11 nun zuerst bedient wird. Drei Besucher waren mit Chrome unterwegs und wurden nur von Version 5.3 erfasst, obwohl diese erst an zweiter Stelle aktiviert wird. Der vierte Besucher (mit Safari) wurde von beiden Statistiken erfasst.
Ich werde nun Statistik 5.3 deaktivieren, was aber eigentlich wieder dem Zustand nach erfolgtem Update entspricht. Mal sehen, ob es jetzt funktioniert.

Gruß
Radioven
Zum Seitenanfang
 
 
IP gespeichert
 
Radioven
Full Member
***
Offline



Beiträge: 132
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #5 - 06.11.22 um 15:51:13
 
Hallo Holger,

es hat sich nach wie vor keine Änderung ergeben. Zunächst will ich meine Beobachtungen noch einmal zusammenfassen:

Leider kann ich die Aussage, daß bei Parallelbetrieb beider Statistikversionen nur die jeweils zuerst aufgerufene zählt, nicht bestätigen. Ich habe zunächst dem Pfad zur Tracking-Datei der jeweiligen Statistik eine Konstante zugewiesen, um eventuelle zukünftige Änderungen nur einmal durchführen zu müssen. In jeder PHP-Seite meiner Homepage ist diese Konstante inkludiert. Dieses Prinzip verwende ich seit über 10 Jahren (seit Version 4.x oder noch eher) ohne Probleme.

Setze ich die beiden include-Befehle in zwei aufeinanderfolgende Zeilen, so zeichnen beide Statistiken auf, allerdings nur bei Benutzern von Firefox oder Safari.
Chrome, Edge und Opera bedienen in diesem Fall nur die Version 5.3, und zwar unabhängig davon, welche Statistik zuerst aufgerufen wird. Das habe ich inzwischen in allen Varianten getestet.

Da ich nun Fehlerquellen in meinen Scripten ausschließen kann, die internen Systemchecks in Statistik v11 sämtlich erfolgreich verlaufen sind, auch alle Plugins tadellos funktionieren und Statistik v5.3 weiterhin unverändert brav ihren Dienst tut, stehe ich vor einem Rätsel. Ich habe die neue Version sowohl als Update von v5.3, als auch als Neuinstallation getestet - leider immer mit dem gleichen Resultat.
Mein persönlicher Verdacht richtet sich gegen die o.g. Browser Chrome, Edge und Opera. Alle drei basieren auf der Chromium-Engine. Außerdem erinnere ich mich daran, daß es vor einigen Monaten ein ähnliches Problem mit einer Firefox-Version gab, das sich aber relativ schnell durch Browser- und Windows-Updates in Luft auflöste:

https://www.php-web-statistik.de/cgi-bin/yabb/YaBB.pl?num=1642343526

Aber das ist, wie gesagt, nur ein Verdacht.
Gibt es eventuell noch andere Forenmitglieder mit ähnlichen Problemen oder bin ich der Einzige? Bis zur Lösung der Angelegenheit werde ich also weiterhin bei Version 5.3 bleiben müssen.

Gruß
Radioven

P.S. Falls es von Bedeutung sein sollte: Die Statistiken laufen derzeit unter Linux und PHP 8.0.25
Zum Seitenanfang
 
 
IP gespeichert
 
Raimund
Full Member
***
Offline



Beiträge: 200
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #6 - 06.11.22 um 18:38:35
 
Also ich habe ganz gegenteilige Erfahrungen. Unter V5.3 wurden zB. Aufrufe von Firefox über Version 98 nicht mehr korrekt erkannt. Die neue Statistik V11 hingegen zeichnet bei mir alle Browser in allen Variationen korrekt auf. Ich habe heute zb. bisher 138 Seitenaufrufe. Und da sind sämtliche Browser, also Firefox, Safari, Chrome, Edge und auch Opera sowohl in älteren, als auch in ihren aktuellsten Versionen vertreten.

Von daher kann eigentlich das Problem nicht, oder zumindest nicht alleine an der neuen Stat-Version 11 liegen.

Ich muss vieleicht noch dazu sagen, das auf meinem Webserver, auf dem meine Webseite und auch die Statistik laufen, noch die php-Version 7.3.33 läuft. Vieleicht spielt die php-Version eine Rolle bei deinen Problemen. 

Grundsätzlich läuft bei mir die V11 reibungslos, abgesehen davon, das immer mal wieder ein Betriebssystem nicht erkannt wird, was bei mir vorher in der V5.3 gar nicht vorkam. Dazu muss man aber auch wieder sagen, das die neue Erkennung viel genauer ist als vorher. Und wenn mehr und vor allem detailierter getrackt wird, steigt auch die Wahrscheinlichkeit, das mal was nicht erkannt wird.
Zum Seitenanfang
 
Homepage  
IP gespeichert
 
Radioven
Full Member
***
Offline



Beiträge: 132
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #7 - 07.11.22 um 09:16:52
 
Ich glaube auch nicht, dass es an der Statistik liegt, denn sonst würde es ja mit keinem Browser funktionieren. Mir erscheint nur auffällig, dass es

1. ausgerechnet bei diesen 3 Browsern nicht funktioniert
2. das Problem scheinbar nur bei mir auftritt

Ich habe die Statistik mittlerweile auch mit einem ganz einfachen HTML-Script getestet, wo ich den Pfad zur pws.php gemäß Anleitung direkt in den Body-Tag reingeschrieben habe. Dabei auch die Firewall abgeschaltet - immer das gleiche Resultat.
Dazu muss ich aber sagen, dass es an meinem Rechner ohnehin nicht liegen kann, da ich bereits mehrere Leute aus meinem Bekanntenkreis beauftragt habe, meine Internetseite mal zu besuchen. Die haben das auch gemacht, aber das Ergebnis deckt sich genau mit meinen eigenen Erfahrungen.

Was kann ich noch tun?

Gruß
Radioven
Zum Seitenanfang
 
 
IP gespeichert
 
Holger
Administrator
*****
Offline



Beiträge: 2267
Germany NRW
Geschlecht: male
Re: Webstat v11 - keine Einträge in Datenbank
Antwort #8 - 07.11.22 um 22:35:46
 
@ Radioven
Du kannst mir mal bitte den Link zur Stat und das Admin Passwort via PN senden damit ich mal näher hingucken kann.

Holger
Zum Seitenanfang
 

... ... ...
Homepage  
IP gespeichert
 
Seitenindex umschalten Seiten: 1
Thema versenden Drucken